openSUSE 10 Security Update : Xerces-c (Xerces-c-6430)

Medium Nessus Plugin ID 41989


The remote openSUSE host is missing a security update.


The Xerces-c package was vulnerable to various bugs while parsing XML.


Update the affected Xerces-c packages.

Plugin Details

Severity: Medium

ID: 41989

File Name: suse_Xerces-c-6430.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2009/10/06

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:Xerces-c, p-cpe:/a:novell:opensuse:libXerces-c-27, p-cpe:/a:novell:opensuse:libXerces-c-devel, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/08/14

Reference Information

CVE: CVE-2009-1885

CWE: 119