SuSE 10 Security Update : IBM Java 1.4.2 (ZYPP Patch Number 6508)

High Nessus Plugin ID 41967

Synopsis

The remote SuSE 10 host is missing a security-related patch.

Description

IBM Java 1.4.2 was updated to SR13 FP1.

It fixes following two security issues: CVE-2009-2625: A vulnerability in the Java Runtime Environment (JRE) with parsing XML data might allow a remote client to create a denial-of-service condition on the system that the JRE runs on.

- A vulnerability in how the Java Runtime Environment (JRE) handles certain RSA public keys might cause the JRE to consume an excessive amount of CPU resources.
This might lead to a Denial of Service (DoS) condition on affected systems. Such keys could be provided by a remote client of an application. (CVE-2008-5349)

This issue affects the following security providers: IBMJCE, IBMPKCS11Impl and IBMJCEFIPS.

Solution

Apply ZYPP patch number 6508.

See Also

http://support.novell.com/security/cve/CVE-2008-5349.html

http://support.novell.com/security/cve/CVE-2009-2625.html

Plugin Details

Severity: High

ID: 41967

File Name: suse_java-1_4_2-ibm-6508.nasl

Version: Revision: 1.11

Type: local

Agent: unix

Published: 2009/10/02

Updated: 2012/06/14

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Patch Publication Date: 2009/09/24

Reference Information

CVE: CVE-2008-5349, CVE-2009-2625

CWE: 264