openSUSE Security Update : postgresql (postgresql-1322)

Medium Nessus Plugin ID 41938


The remote openSUSE host is missing a security update.


Multiple security vulnerabilities have been fixed in PostgrSQL

- CVE-2009-3229: allows remote authenticated users to cause a denial of service

- CVE-2009-3230: allows remote authenticated users to gain higher privileges

- CVE-2009-3231: when using LDAP authentication with anonymous binds, allows remote attackers to bypass authentication via an empty password


Update the affected postgresql packages.

See Also

Plugin Details

Severity: Medium

ID: 41938

File Name: suse_11_0_postgresql-090917.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2009/09/29

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:postgresql, p-cpe:/a:novell:opensuse:postgresql-contrib, p-cpe:/a:novell:opensuse:postgresql-devel, p-cpe:/a:novell:opensuse:postgresql-libs, p-cpe:/a:novell:opensuse:postgresql-libs-32bit, p-cpe:/a:novell:opensuse:postgresql-server, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/09/17

Reference Information

CVE: CVE-2009-3229, CVE-2009-3230, CVE-2009-3231

CWE: 264, 287