SuSE 11 Security Update : nagios (SAT Patch Number 1105)

High Nessus Plugin ID 41439


The remote SuSE 11 host is missing one or more security updates.


A shell injection bug in nagios' statuswml.cgi CGI script has been fixed. CVE-2009-2288 has been assigned to this issue.


Apply SAT patch number 1105.

See Also

Plugin Details

Severity: High

ID: 41439

File Name: suse_11_nagios-090715.nasl

Version: $Revision: 1.11 $

Type: local

Agent: unix

Published: 2009/09/24

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:nagios, p-cpe:/a:novell:suse_linux:11:nagios-www, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/07/15

Exploitable With


Core Impact

Metasploit (Nagios3 statuswml.cgi Ping Command Execution)

Elliot (Nagios 3.1.0 RCE)

Reference Information

CVE: CVE-2009-2288

CWE: 78