SuSE 11 Security Update : udev (SAT Patch Number 766)

High Nessus Plugin ID 41432


The remote SuSE 11 host is missing one or more security updates.


This update fixes a local privilege escalation in udev.

- udev did not check the origin of the netlink messages. A local attacker could fake device create events and so gain root privileges. (CVE-2009-1185)


Apply SAT patch number 766.

See Also

Plugin Details

Severity: High

ID: 41432

File Name: suse_11_libudev-devel-090414.nasl

Version: $Revision: 1.13 $

Type: local

Agent: unix

Published: 2009/09/24

Modified: 2013/11/29

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:libvolume_id1, p-cpe:/a:novell:suse_linux:11:udev, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/04/14

Exploitable With


Core Impact

Metasploit (Linux udev Netlink Local Privilege Escalation)

Reference Information

CVE: CVE-2009-1185

CWE: 20