SuSE 11 Security Update : lcms (SAT Patch Number 635)

High Nessus Plugin ID 41417


The remote SuSE 11 host is missing one or more security updates.


Specially crafted image files could cause an integer overflow in lcms.
Attackers could potentially exploit that to crash applications using lcms or even execute arbitrary code. (CVE-2009-0723 / CVE-2009-0581 / CVE-2009-0733)


Apply SAT patch number 635.

See Also

Plugin Details

Severity: High

ID: 41417

File Name: suse_11_lcms-090317.nasl

Version: $Revision: 1.10 $

Type: local

Agent: unix

Published: 2009/09/24

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:lcms, p-cpe:/a:novell:suse_linux:11:liblcms1, p-cpe:/a:novell:suse_linux:11:liblcms1-32bit, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2009/03/17

Reference Information

CVE: CVE-2009-0581, CVE-2009-0723, CVE-2009-0733

CWE: 119, 189, 399