SuSE 11 Security Update : gstreamer (SAT Patch Number 742)

High Nessus Plugin ID 41400


The remote SuSE 11 host is missing one or more security updates.


Specially crafted cover art tags in vorbis files could trigger a heap overflow in the base64 decoder. Attackers could potentially exploit that to execute arbitrary code. (CVE-2009-0586)


Apply SAT patch number 742.

See Also

Plugin Details

Severity: High

ID: 41400

File Name: suse_11_gstreamer-0_10-plugins-base-090406.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2009/09/24

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:gstreamer-0_10-plugins-base, p-cpe:/a:novell:suse_linux:11:gstreamer-0_10-plugins-base-32bit, p-cpe:/a:novell:suse_linux:11:gstreamer-0_10-plugins-base-doc, p-cpe:/a:novell:suse_linux:11:gstreamer-0_10-plugins-base-lang, p-cpe:/a:novell:suse_linux:11:libgstinterfaces-0_10-0, p-cpe:/a:novell:suse_linux:11:libgstinterfaces-0_10-0-32bit, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2009/04/06

Reference Information

CVE: CVE-2009-0586

CWE: 189