SuSE 11 Security Update : cyrus-sasl (SAT Patch Number 881)

High Nessus Plugin ID 41381

Synopsis

The remote SuSE 11 host is missing one or more security updates.

Description

This update of cyrus-sasl improves the output of function sasl_encode64() by appending a 0 for string termination. The impact depends on the application that uses sasl_encode64(). (CVE-2009-0688)

Solution

Apply SAT patch number 881.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=499104

http://support.novell.com/security/cve/CVE-2009-0688.html

Plugin Details

Severity: High

ID: 41381

File Name: suse_11_cyrus-sasl-090514.nasl

Version: Revision: 1.10

Type: local

Agent: unix

Published: 2009/09/24

Updated: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:cyrus-sasl, p-cpe:/a:novell:suse_linux:11:cyrus-sasl-32bit, p-cpe:/a:novell:suse_linux:11:cyrus-sasl-crammd5, p-cpe:/a:novell:suse_linux:11:cyrus-sasl-crammd5-32bit, p-cpe:/a:novell:suse_linux:11:cyrus-sasl-digestmd5, p-cpe:/a:novell:suse_linux:11:cyrus-sasl-digestmd5-32bit, p-cpe:/a:novell:suse_linux:11:cyrus-sasl-gssapi, p-cpe:/a:novell:suse_linux:11:cyrus-sasl-gssapi-32bit, p-cpe:/a:novell:suse_linux:11:cyrus-sasl-otp, p-cpe:/a:novell:suse_linux:11:cyrus-sasl-otp-32bit, p-cpe:/a:novell:suse_linux:11:cyrus-sasl-plain, p-cpe:/a:novell:suse_linux:11:cyrus-sasl-plain-32bit, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2009/05/14

Reference Information

CVE: CVE-2009-0688

CWE: 119