SuSE 11 Security Update : Mozilla Firefox (SAT Patch Number 1200)

Critical Nessus Plugin ID 41358

Synopsis

The remote SuSE 11 host is missing one or more security updates.

Description

Mozilla Firefox was updated to the 3.0.13 release, fixing some security issues and bugs :

- Security researcher Juan Pablo Lopez Yacubian reported that an attacker could call window.open() on an invalid URL which looks similar to a legitimate URL and then use document.write() to place content within the new document, appearing to have come from the spoofed location. Additionally, if the spoofed document was created by a document with a valid SSL certificate, the SSL indicators would be carried over into the spoofed document. An attacker could use these issues to display misleading location and SSL information for a malicious web page. (MFSA 2009-44 / CVE-2009-2654)

- The browser engine in Mozilla Firefox before 3.0.13, and 3.5.x before 3.5.2, allows remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via vectors related to the TraceRecorder::snapshot function in js/src/jstracer.cpp, and unspecified other vectors.
(MFSA 2009-45 / CVE-2009-2662)

- libvorbis before r16182, as used in Mozilla Firefox before 3.0.13 and 3.5.x before 3.5.2 and other products, allows context-dependent attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via a crafted .ogg file.
(CVE-2009-2663 / MFSA 2009-45)

- The js_watch_set function in js/src/jsdbgapi.cpp in the JavaScript engine in Mozilla Firefox before 3.0.13, and 3.5.x before 3.5.2, allows remote attackers to cause a denial of service (assertion failure and application exit) or possibly execute arbitrary code via a crafted .js file, related to a 'memory safety bug.'.
(CVE-2009-2664 / MFSA 2009-45)

Solution

Apply SAT patch number 1200.

See Also

http://www.mozilla.org/security/announce/2009/mfsa2009-44.html

http://www.mozilla.org/security/announce/2009/mfsa2009-45.html

https://bugzilla.novell.com/show_bug.cgi?id=527489

http://support.novell.com/security/cve/CVE-2009-2654.html

http://support.novell.com/security/cve/CVE-2009-2662.html

http://support.novell.com/security/cve/CVE-2009-2663.html

http://support.novell.com/security/cve/CVE-2009-2664.html

Plugin Details

Severity: Critical

ID: 41358

File Name: suse_11_MozillaFirefox-090812.nasl

Version: 1.13

Type: local

Agent: unix

Published: 2009/09/24

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:MozillaFirefox, p-cpe:/a:novell:suse_linux:11:MozillaFirefox-translations, p-cpe:/a:novell:suse_linux:11:gconf2, p-cpe:/a:novell:suse_linux:11:gconf2-32bit, p-cpe:/a:novell:suse_linux:11:libidl, p-cpe:/a:novell:suse_linux:11:libidl-32bit, p-cpe:/a:novell:suse_linux:11:mozilla-xulrunner190, p-cpe:/a:novell:suse_linux:11:mozilla-xulrunner190-32bit, p-cpe:/a:novell:suse_linux:11:mozilla-xulrunner190-gnomevfs, p-cpe:/a:novell:suse_linux:11:mozilla-xulrunner190-gnomevfs-32bit, p-cpe:/a:novell:suse_linux:11:mozilla-xulrunner190-translations, p-cpe:/a:novell:suse_linux:11:mozilla-xulrunner190-translations-32bit, p-cpe:/a:novell:suse_linux:11:orbit2, p-cpe:/a:novell:suse_linux:11:orbit2-32bit, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2009/08/12

Reference Information

CVE: CVE-2009-2654, CVE-2009-2662, CVE-2009-2663, CVE-2009-2664

CWE: 20, 119, 399