SuSE9 Security Update : net-snmp (YOU Patch Number 12298)

Medium Nessus Plugin ID 41256


The remote SuSE 9 host is missing a security-related patch.


Remote attackers could crash net-snmp via GETBULK-Request.

In addition the following non-security issues have been fixed :

- typo in error message (bnc#439857)

- make OIDs longer than 256 chars work (bnc#345914)

- typo in the snmpd init script to really load all agents (bnc#415127)

- logrotate config to restart the snmptrapd aswell (bnc#378069)


Apply YOU patch number 12298.

See Also

Plugin Details

Severity: Medium

ID: 41256

File Name: suse9_12298.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2009/09/24

Modified: 2012/04/23

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2008/11/22

Reference Information

CVE: CVE-2008-4309

CWE: 20