SuSE9 Security Update : pcre (YOU Patch Number 11998)

Medium Nessus Plugin ID 41169

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.8

Synopsis

The remote SuSE 9 host is missing a security-related patch.

Description

Specially crafted regular expressions could lead to a buffer overflow in the pcre library. Applications using pcre to process regular expressions from untrusted sources could therefore potentially be exploited by attackers to execute arbitrary code. (CVE-2007-1659, CVE-2006-7230)

Solution

Apply YOU patch number 11998.

See Also

http://support.novell.com/security/cve/CVE-2006-7230.html

http://support.novell.com/security/cve/CVE-2007-1659.html

Plugin Details

Severity: Medium

ID: 41169

File Name: suse9_11998.nasl

Version: 1.9

Type: local

Agent: unix

Published: 2009/09/24

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium

VPR Score: 5.8

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2007/11/28

Reference Information

CVE: CVE-2006-7230, CVE-2007-1659

CWE: 119, 189