SuSE9 Security Update : SLES9-SP4: Security update for lprng (YOU Patch Number 11603)

High Nessus Plugin ID 41140


The remote SuSE 9 host is missing a security-related patch.


- There is a (small) memory leak in lpd which lets its memory usage grow a bit for each print job until the print system becomes unusable.

- Using lprng with a printcap provided via NIS/YP produced following error: 'Init_tempfile: bad tempdir '/var/spool/lpd/%P''. This was caused by the function 'Init_tempfile()', which tried to create tmpfiles in the spool directory, which was not expanded at this time.
Patched version creates tmpfiles in tmpdir, when spooldir is not yet expanded.


Apply YOU patch number 11603.

Plugin Details

Severity: High

ID: 41140

File Name: suse9_11603.nasl

Version: $Revision: 1.4 $

Type: local

Agent: unix

Published: 2009/09/24

Modified: 2012/04/23

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2007/11/15