SuSE9 Security Update : perl-Compress-Zlib (YOU Patch Number 10292)

High Nessus Plugin ID 41077


The remote SuSE 9 host is missing a security-related patch.


perl-Compress-Zlib included a copy of zlib which is vulnerable to a denial of service attack tracked by the Mitre CVE CVE-2005-2096.

This update removed the use of the internal copy and now uses the external version of zlib.


Apply YOU patch number 10292.

See Also

Plugin Details

Severity: High

ID: 41077

File Name: suse9_10292.nasl

Version: $Revision: 1.4 $

Type: local

Agent: unix

Published: 2009/09/24

Modified: 2012/04/23

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2005/07/06

Reference Information

CVE: CVE-2005-2096