openSUSE Security Update : silc-toolkit (silc-toolkit-1280)

High Nessus Plugin ID 41003


The remote openSUSE host is missing a security update.


This update of slic-toolkit fixes stack-based overflow while encoding a ASN.1 OID (CVE-2008-7159) and several format string bugs (CVE-2009-3051, CVE-2008-7160). The probability to exploit this issues to execute arbitrary code is high.


Update the affected silc-toolkit packages.

See Also

Plugin Details

Severity: High

ID: 41003

File Name: suse_11_0_silc-toolkit-090908.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2009/09/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:silc-toolkit, p-cpe:/a:novell:opensuse:silc-toolkit-devel, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/09/08

Reference Information

CVE: CVE-2008-7159, CVE-2008-7160, CVE-2009-3051

CWE: 134