openSUSE Security Update : OpenEXR (OpenEXR-1157)

High Nessus Plugin ID 40841


The remote openSUSE host is missing a security update.


This update of OpenEXR fixes seceral integer overflows (CVE-2009-1720) and a denial-of-service (probably execution of arbitrary code) bug (CVE-2009-1721).


Update the affected OpenEXR packages.

See Also

Plugin Details

Severity: High

ID: 40841

File Name: suse_11_0_OpenEXR-090804.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2009/09/02

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:OpenEXR, p-cpe:/a:novell:opensuse:OpenEXR-32bit, p-cpe:/a:novell:opensuse:OpenEXR-devel, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/08/04

Reference Information

CVE: CVE-2009-1720, CVE-2009-1721

CWE: 16, 189