Mandriva Linux Security Advisory : libgadu (MDVSA-2009:208-1)

Medium Nessus Plugin ID 40693


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability has been found and corrected in libgadu :

libgadu before 1.8.2 allows remote servers to cause a denial of service (crash) via a contact description with a large length, which triggers a buffer over-read (CVE-2008-4776).

This update provides a solution to this vulnerability.

Update :

Packages for 2008.0 are provided for Corporate Desktop 2008.0 customers


Update the affected packages.

Plugin Details

Severity: Medium

ID: 40693

File Name: mandriva_MDVSA-2009-208.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2009/08/24

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64gadu-devel, p-cpe:/a:mandriva:linux:lib64gadu-static-devel, p-cpe:/a:mandriva:linux:lib64gadu3, p-cpe:/a:mandriva:linux:libgadu-devel, p-cpe:/a:mandriva:linux:libgadu-static-devel, p-cpe:/a:mandriva:linux:libgadu3, cpe:/o:mandriva:linux:2008.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2009/12/04

Reference Information

CVE: CVE-2008-4776

MDVSA: 2009:208-1

CWE: 119