FreeBSD : subversion -- heap overflow vulnerability (bce1f76d-82d0-11de-88ea-001a4d49522b)

High Nessus Plugin ID 40508


The remote FreeBSD host is missing one or more security-related updates.


A Subversion Security Advisory reports :

Subversion clients and servers have multiple heap overflow issues in the parsing of binary deltas. This is related to an allocation vulnerability in the APR library used by Subversion.

Clients with commit access to a vulnerable server can cause a remote heap overflow; servers can cause a heap overflow on vulnerable clients that try to do a checkout or update.

This can lead to a DoS (an exploit has been tested) and to arbitrary code execution (no exploit tested, but the possibility is clear).


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 40508

File Name: freebsd_pkg_bce1f76d82d011de88ea001a4d49522b.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2009/08/07

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 8.5

Vector: CVSS2#AV:N/AC:M/Au:S/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:p5-subversion, p-cpe:/a:freebsd:freebsd:py-subversion, p-cpe:/a:freebsd:freebsd:subversion, p-cpe:/a:freebsd:freebsd:subversion-freebsd, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2009/08/06

Vulnerability Publication Date: 2009/08/06

Reference Information

CVE: CVE-2009-2411

CWE: 189