Squid 3.0.STABLE16 / 3.10.11

medium Nessus Plugin ID 40420
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote proxy server is prone to denial of service attacks.

Description

According to its banner, the version of the Squid proxy caching server installed on the remote host is older than 3.0.STABLE17 or 3.1.0.12.
Such versions reportedly use incorrect bounds checking when processing some requests or responses.

Squid-2.x releases are not vulnerable.

Solution

Either upgrade to Squid version 3.0.STABLE17 or 3.1.0.12 or later or apply the patch referenced in the project's advisory above.

See Also

http://www.squid-cache.org/Advisories/SQUID-2009_2.txt

http://www.securityfocus.com/advisories/17446

http://www.securityfocus.com/advisories/17448

http://www.securityfocus.com/advisories/17483

Plugin Details

Severity: Medium

ID: 40420

File Name: squid_3_0_16.nasl

Version: 1.13

Type: remote

Family: Firewalls

Published: 7/29/2009

Updated: 7/30/2018

Dependencies: squid_version.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 5.1

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: www/squid, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 7/27/2009

Vulnerability Publication Date: 7/27/2009

Reference Information

CVE: CVE-2009-2621, CVE-2009-2622

BID: 35812

CWE: 20, 119