openSUSE Security Update : xrdp (xrdp-458)

High Nessus Plugin ID 40326


The remote openSUSE host is missing a security update.


This update fixes multiple buffer overflows that can be exploited remotely to execute arbitrary code. (CVE-2008-5902, CVE-2008-5903, CVE-2008-5904) Additionally xrdp does not register remote session as local anymore.

Please note, the previous update was missing the patch.


Update the affected xrdp package.

See Also

Plugin Details

Severity: High

ID: 40326

File Name: suse_11_1_xrdp-090121.nasl

Version: $Revision: 1.10 $

Type: local

Agent: unix

Published: 2009/07/21

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:xrdp, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/01/21

Reference Information

CVE: CVE-2008-5902, CVE-2008-5903, CVE-2008-5904

CWE: 20, 119, 189