openSUSE Security Update : strongswan (strongswan-965)

Medium Nessus Plugin ID 40312


The remote openSUSE host is missing a security update.


This update fixes two denial of service bugs that can lead to a remote pre-auth crash while processing a IKE_SA_INIT or a IKE_AUTH request.
CVE-2009-1957 and CVE-2009-1958 have been assigned to this issue.


Update the affected strongswan package.

See Also

Plugin Details

Severity: Medium

ID: 40312

File Name: suse_11_1_strongswan-090608.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2009/07/21

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:strongswan, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/06/08

Reference Information

CVE: CVE-2009-1957, CVE-2009-1958

CWE: 399