openSUSE Security Update : rsyslog (rsyslog-367)

High Nessus Plugin ID 40304


The remote openSUSE host is missing a security update.


rsyslog ignored the $AllowedSender configuration directive, therefore accepting log messages from anyone (CVE-2008-5617).

Additionally imudp logged a message when unauthorized senders tried to send to it, therefore allowing attackers to flood the log CVE-2008-5618).


Update the affected rsyslog package.

See Also

Plugin Details

Severity: High

ID: 40304

File Name: suse_11_1_rsyslog-081217.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2009/07/21

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 8.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:rsyslog, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/12/17

Reference Information

CVE: CVE-2008-5617, CVE-2008-5618

CWE: 264