openSUSE Security Update : perl (perl-995)

Medium Nessus Plugin ID 40296


The remote openSUSE host is missing a security update.


A Buffer overflow in perl, in the base Compress::Raw::Zlib perl module has been fixed. (CVE-2009-1391)

Additionaly three non security bugs were fixed.


Update the affected perl packages.

See Also

Plugin Details

Severity: Medium

ID: 40296

File Name: suse_11_1_perl-090610.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2009/07/21

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:perl, p-cpe:/a:novell:opensuse:perl-32bit, p-cpe:/a:novell:opensuse:perl-base, p-cpe:/a:novell:opensuse:perl-base-32bit, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/06/10

Reference Information

CVE: CVE-2009-1391

CWE: 189