openSUSE Security Update : libxine-devel (libxine-devel-582)

High Nessus Plugin ID 40274


The remote openSUSE host is missing a security update.


Specially crafted 4x movie files could cause an integer overflow in xine-lib (CVE-2009-0698).


Update the affected libxine-devel packages.

See Also

Plugin Details

Severity: High

ID: 40274

File Name: suse_11_1_libxine-devel-090309.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2009/07/21

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libxine-devel, p-cpe:/a:novell:opensuse:libxine1, p-cpe:/a:novell:opensuse:libxine1-32bit, p-cpe:/a:novell:opensuse:libxine1-gnome-vfs, p-cpe:/a:novell:opensuse:libxine1-pulse, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/03/09

Reference Information

CVE: CVE-2009-0698

CWE: 189