openSUSE Security Update : libopenssl-devel (libopenssl-devel-974)

Medium Nessus Plugin ID 40262


The remote openSUSE host is missing a security update.


OpenSSL DTLS remote DoS in ChangeCipherSpec (CVE-2009-1386) and in out-of-sequence message handling (CVE-2009-1387) have been fixed.


Update the affected libopenssl-devel packages.

See Also

Plugin Details

Severity: Medium

ID: 40262

File Name: suse_11_1_libopenssl-devel-090609.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2009/07/21

Modified: 2015/01/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libopenssl-devel, p-cpe:/a:novell:opensuse:libopenssl0_9_8, p-cpe:/a:novell:opensuse:libopenssl0_9_8-32bit, p-cpe:/a:novell:opensuse:openssl, p-cpe:/a:novell:opensuse:openssl-certs, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/06/09

Exploitable With

Core Impact

Reference Information

CVE: CVE-2009-1386, CVE-2009-1387

CWE: 399