openSUSE Security Update : gstreamer-0_10-plugins-good (gstreamer-0_10-plugins-good-540)

High Nessus Plugin ID 40227


The remote openSUSE host is missing a security update.


gstreamer-0_10: several heap overflows (CVE-2009-0386, CVE-2009-0387,CVE-2009-0397) have been fixed. Remote attackers could exploit these to execute arbitrary code via QuickTime media files.


Update the affected gstreamer-0_10-plugins-good packages.

See Also

Plugin Details

Severity: High

ID: 40227

File Name: suse_11_1_gstreamer-0_10-plugins-good-090218.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2009/07/21

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gstreamer-0_10-plugins-good, p-cpe:/a:novell:opensuse:gstreamer-0_10-plugins-good-extra, p-cpe:/a:novell:opensuse:gstreamer-0_10-plugins-good-lang, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/02/18

Reference Information

CVE: CVE-2009-0386, CVE-2009-0387, CVE-2009-0397

CWE: 119