openSUSE Security Update : gstreamer-0_10-plugins-bad (gstreamer-0_10-plugins-bad-887)

High Nessus Plugin ID 40225


The remote openSUSE host is missing a security update.


This update fixes a buffer overflow in libmodplug that can be exploited remotely to execute arbitrary code with the privileges of the process using the libaray. (CVE-2009-1438)


Update the affected gstreamer-0_10-plugins-bad packages.

See Also

Plugin Details

Severity: High

ID: 40225

File Name: suse_11_1_gstreamer-0_10-plugins-bad-090514.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2009/07/21

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gstreamer-0_10-plugins-bad, p-cpe:/a:novell:opensuse:gstreamer-0_10-plugins-bad-devel, p-cpe:/a:novell:opensuse:gstreamer-0_10-plugins-bad-lang, p-cpe:/a:novell:opensuse:libgstapp-0_10-0, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/05/14

Reference Information

CVE: CVE-2009-1438

CWE: 189