openSUSE Security Update : evolution (evolution-776)

Medium Nessus Plugin ID 40214

Synopsis

The remote openSUSE host is missing a security update.

Description

camel's NTLM SASL authentication mechanism as used by evolution did not properly validate server's challenge packets (CVE-2009-0582).

This update also includes the following non-security fixes :

- Fixes a critical crasher in mailer component.

- Fixes creation of recurrence monthly items in GroupWise.

- Includes fixes for some usability issues.

Solution

Update the affected evolution packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=419303

https://bugzilla.novell.com/show_bug.cgi?id=475541

https://bugzilla.novell.com/show_bug.cgi?id=477697

https://bugzilla.novell.com/show_bug.cgi?id=479908

https://bugzilla.novell.com/show_bug.cgi?id=480091

https://bugzilla.novell.com/show_bug.cgi?id=484213

Plugin Details

Severity: Medium

ID: 40214

File Name: suse_11_1_evolution-090416.nasl

Version: 1.10

Type: local

Agent: unix

Published: 2009/07/21

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:evolution, p-cpe:/a:novell:opensuse:evolution-data-server, p-cpe:/a:novell:opensuse:evolution-data-server-32bit, p-cpe:/a:novell:opensuse:evolution-data-server-devel, p-cpe:/a:novell:opensuse:evolution-data-server-lang, p-cpe:/a:novell:opensuse:evolution-devel, p-cpe:/a:novell:opensuse:evolution-lang, p-cpe:/a:novell:opensuse:evolution-mono-providers, p-cpe:/a:novell:opensuse:evolution-pilot, p-cpe:/a:novell:opensuse:gtkhtml2, p-cpe:/a:novell:opensuse:gtkhtml2-devel, p-cpe:/a:novell:opensuse:gtkhtml2-lang, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/04/16

Reference Information

CVE: CVE-2009-0582

CWE: 20