openSUSE Security Update : amarok (amarok-436)

High Nessus Plugin ID 40185


The remote openSUSE host is missing a security update.


This update of amarok fixes several integer overflows and unchecked memory allocations that can be exploited by malformed Audible digital audio files. These bugs could be used in a user-assisted attack scenario to execute arbitrary code remotely. (CVE-2009-0135, CVE-2009-0136)


Update the affected amarok packages.

See Also

Plugin Details

Severity: High

ID: 40185

File Name: suse_11_1_amarok-090119.nasl

Version: $Revision: 1.10 $

Type: local

Agent: unix

Published: 2009/07/21

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:amarok, p-cpe:/a:novell:opensuse:amarok-lang, p-cpe:/a:novell:opensuse:amarok-libvisual, p-cpe:/a:novell:opensuse:amarok-xine, p-cpe:/a:novell:opensuse:amarok-yauap, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/01/19

Reference Information

CVE: CVE-2009-0135, CVE-2009-0136

CWE: 119, 189