openSUSE Security Update : rubygem-activerecord (rubygem-activerecord-328)

High Nessus Plugin ID 40124


The remote openSUSE host is missing a security update.


Missing sanity checks of the :limit and :offset parameters in SQL queries could potentially be exploited to conduct SQL inection attacks (CVE-2008-4094).


Update the affected rubygem-activerecord package.

See Also

Plugin Details

Severity: High

ID: 40124

File Name: suse_11_0_rubygem-activerecord-081122.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2009/07/21

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:rubygem-activerecord, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/11/22

Reference Information

CVE: CVE-2008-4094

CWE: 89