openSUSE Security Update : phpMyAdmin (phpMyAdmin-711)

High Nessus Plugin ID 40108

Synopsis

The remote openSUSE host is missing a security update.

Description

This update of phpMyAdmin fixes multiple vulnerabilities :

- CVE-2009-1148: directory traversal

- CVE-2009-1149: CRLF injection

- CVE-2009-1150: cross-site scripting

- CVE-2009-1151: static code injection

Solution

Update the affected phpMyAdmin package.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=490596

Plugin Details

Severity: High

ID: 40108

File Name: suse_11_0_phpMyAdmin-090401.nasl

Version: 1.15

Type: local

Agent: unix

Published: 2009/07/21

Updated: 2019/02/07

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:phpMyAdmin, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/04/01

Vulnerability Publication Date: 2009/03/26

Exploitable With

CANVAS (CANVAS)

Core Impact

Metasploit (PhpMyAdmin Config File Code Injection)

Elliot (Phpmyadmin File Upload)

Reference Information

CVE: CVE-2009-1148, CVE-2009-1149, CVE-2009-1150, CVE-2009-1151

CWE: 20, 22, 79, 94