openSUSE Security Update : libxslt (libxslt-110)

High Nessus Plugin ID 40059


The remote openSUSE host is missing a security update.


A heap overflow in the RC4 cryptographic routines in libxslt was fixed which could be used by attackers to potentially execute code.


Update the affected libxslt packages.

See Also

Plugin Details

Severity: High

ID: 40059

File Name: suse_11_0_libxslt-080720.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2009/07/21

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libxslt, p-cpe:/a:novell:opensuse:libxslt-32bit, p-cpe:/a:novell:opensuse:libxslt-devel, p-cpe:/a:novell:opensuse:libxslt-devel-32bit, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/07/20

Reference Information

CVE: CVE-2008-2935

CWE: 119