openSUSE Security Update : libxml2 (libxml2-184)

Critical Nessus Plugin ID 40056


The remote openSUSE host is missing a security update.


Specially crafted xml files could cause a crash or a heap based buffer overlow in libxml2 (CVE-2008-3281, CVE-2008-3529).


Update the affected libxml2 packages.

See Also

Plugin Details

Severity: Critical

ID: 40056

File Name: suse_11_0_libxml2-080905.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2009/07/21

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libxml2, p-cpe:/a:novell:opensuse:libxml2-32bit, p-cpe:/a:novell:opensuse:libxml2-devel, p-cpe:/a:novell:opensuse:libxml2-devel-32bit, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/09/05

Reference Information

CVE: CVE-2008-3281, CVE-2008-3529

CWE: 119, 399