openSUSE Security Update : libwsman-devel (libwsman-devel-157)

High Nessus Plugin ID 40053


The remote openSUSE host is missing a security update.


This update of openwsman fixes several security vulnerabilities found by the SuSE Security-Team :

- remote buffer overflows while decoding the HTTP basic authentication header (CVE-2008-2234)

- a possible SSL session replay attack affecting the client (depending on the configuration) (CVE-2008-2233)


Update the affected libwsman-devel packages.

See Also

Plugin Details

Severity: High

ID: 40053

File Name: suse_11_0_libwsman-devel-080814.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2009/07/21

Modified: 2016/12/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libwsman-devel, p-cpe:/a:novell:opensuse:libwsman1, p-cpe:/a:novell:opensuse:openwsman-client, p-cpe:/a:novell:opensuse:openwsman-python, p-cpe:/a:novell:opensuse:openwsman-ruby, p-cpe:/a:novell:opensuse:openwsman-server, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/08/14

Reference Information

CVE: CVE-2008-2233, CVE-2008-2234

IAVB: 2008-B-0064

CWE: 94, 119