openSUSE Security Update : irssi (irssi-1004)

Medium Nessus Plugin ID 39994


The remote openSUSE host is missing a security update.


Fixed a irssi off by one overflow in the event_wallops() function.
CVE-2009-1959 has been assigned to this issue.


Update the affected irssi packages.

See Also

Plugin Details

Severity: Medium

ID: 39994

File Name: suse_11_0_irssi-090615.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2009/07/21

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:irssi, p-cpe:/a:novell:opensuse:irssi-devel, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/06/15

Reference Information

CVE: CVE-2009-1959

CWE: 189