openSUSE Security Update : htop (htop-332)

Medium Nessus Plugin ID 39986


The remote openSUSE host is missing a security update.


insufficient character filters in htop when displaying commands allowed programs that rewrite their program name to inject escape sequences (CVE-2008-5076).


Update the affected htop package.

See Also

Plugin Details

Severity: Medium

ID: 39986

File Name: suse_11_0_htop-081124.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2009/07/21

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:htop, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2008/11/24

Reference Information

CVE: CVE-2008-5076

CWE: 200