openSUSE Security Update : glib2 (glib2-815)

Medium Nessus Plugin ID 39971

Synopsis

The remote openSUSE host is missing a security update.

Description

Large strings could lead to a heap overflow in the base64 encoding and decoding functions. Attackers could potentially exploit that to execute arbitrary code (CVE-2008-4316).

Solution

Update the affected glib2 packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=449927

Plugin Details

Severity: Medium

ID: 39971

File Name: suse_11_0_glib2-090422.nasl

Version: Revision: 1.8

Type: local

Agent: unix

Published: 2009/07/21

Updated: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:glib2, p-cpe:/a:novell:opensuse:glib2-branding-upstream, p-cpe:/a:novell:opensuse:glib2-devel, p-cpe:/a:novell:opensuse:glib2-lang, p-cpe:/a:novell:opensuse:libgio-2_0-0, p-cpe:/a:novell:opensuse:libgio-2_0-0-32bit, p-cpe:/a:novell:opensuse:libgio-fam, p-cpe:/a:novell:opensuse:libglib-2_0-0, p-cpe:/a:novell:opensuse:libglib-2_0-0-32bit, p-cpe:/a:novell:opensuse:libgmodule-2_0-0, p-cpe:/a:novell:opensuse:libgmodule-2_0-0-32bit, p-cpe:/a:novell:opensuse:libgobject-2_0-0, p-cpe:/a:novell:opensuse:libgobject-2_0-0-32bit, p-cpe:/a:novell:opensuse:libgthread-2_0-0, p-cpe:/a:novell:opensuse:libgthread-2_0-0-32bit, cpe:/o:novell:opensuse:11.0

Patch Publication Date: 2009/04/22

Reference Information

CVE: CVE-2008-4316

CWE: 189