openSUSE Security Update : flash-player (flash-player-560)

High Nessus Plugin ID 39962


The remote openSUSE host is missing a security update.


Specially crafted swf files could cause a buffer overflow in flash-player. Attackers could potentially exploit that to execute code on the victim's machine (CVE-2009-0519, CVE-2009-0520, CVE-2009-0114, CVE-2009-0521).


Update the affected flash-player package.

See Also

Plugin Details

Severity: High

ID: 39962

File Name: suse_11_0_flash-player-090226.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2009/07/21

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:flash-player, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/02/26

Reference Information

CVE: CVE-2009-0114, CVE-2009-0519, CVE-2009-0520, CVE-2009-0521

CWE: 20, 119, 200