Slackware 11.0 / 12.0 / 12.1 / 12.2 / current : apr-util (SSA:2009-167-02)

High Nessus Plugin ID 39422


The remote Slackware host is missing a security update.


New apr-util (and apr) packages are available for Slackware 11.0, 12.0, 12.1, 12.2, and -current to fix security issues. The issues are with apr-util, but older Slackware releases will require a new version of the apr package as well.


Update the affected apr and / or apr-util packages.

See Also

Plugin Details

Severity: High

ID: 39422

File Name: Slackware_SSA_2009-167-02.nasl

Version: $Revision: 1.18 $

Type: local

Published: 2009/06/17

Modified: 2016/12/09

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:apr, p-cpe:/a:slackware:slackware_linux:apr-util, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:11.0, cpe:/o:slackware:slackware_linux:12.0, cpe:/o:slackware:slackware_linux:12.1, cpe:/o:slackware:slackware_linux:12.2

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/06/16

Reference Information

CVE: CVE-2009-0023, CVE-2009-1955

BID: 35221, 35253

OSVDB: 55057, 55059

SSA: 2009-167-02

CWE: 119, 399