openSUSE 10 Security Update : quagga (quagga-6233)

Medium Nessus Plugin ID 39418


The remote openSUSE host is missing a security update.


This update fixes a remote denial of service bug in quagga that can be triggered via an AS path containing ASN elements whose string representation is longer than expected. (CVE-2009-1572)


Update the affected quagga packages.

Plugin Details

Severity: Medium

ID: 39418

File Name: suse_quagga-6233.nasl

Version: $Revision: 1.4 $

Type: local

Agent: unix

Published: 2009/06/16

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:quagga, p-cpe:/a:novell:opensuse:quagga-devel, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/05/08

Reference Information

CVE: CVE-2009-1572