openSUSE 10 Security Update : libopenssl-devel (libopenssl-devel-6268)

Medium Nessus Plugin ID 38923

Synopsis

The remote openSUSE host is missing a security update.

Description

Three remote DoS vulnerabilities have been fixed in OpenSSL: a DTLS epoch record buffer memory DoS (CVE-2009-1377), a DTLS fragment handling memory DoS (CVE-2009-1378) and a DTLS fragment read after a free DoS (CVE-2009-1379).

Solution

Update the affected libopenssl-devel packages.

Plugin Details

Severity: Medium

ID: 38923

File Name: suse_libopenssl-devel-6268.nasl

Version: 1.8

Type: local

Agent: unix

Published: 2009/05/27

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libopenssl-devel, p-cpe:/a:novell:opensuse:libopenssl0_9_8, p-cpe:/a:novell:opensuse:libopenssl0_9_8-32bit, p-cpe:/a:novell:opensuse:openssl, p-cpe:/a:novell:opensuse:openssl-certs, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/05/22

Reference Information

CVE: CVE-2009-1377, CVE-2009-1378, CVE-2009-1379

CWE: 119, 399