openSUSE 10 Security Update : xntp (xntp-6231)

Medium Nessus Plugin ID 38847


The remote openSUSE host is missing a security update.


This update fixes a remote buffer overflow in xntp/ntp which can be exploited when autokey is enabled to execute arbitrary code.
(CVE-2009-1252) This upfate fixes a buffer overflow in ntpd that can be triggered by a malicious server. (CVE-2009-0159)


Update the affected xntp package.

Plugin Details

Severity: Medium

ID: 38847

File Name: suse_xntp-6231.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2009/05/20

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:xntp, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/05/08

Reference Information

CVE: CVE-2009-0159, CVE-2009-1252

CWE: 119