FreeBSD : nsd -- buffer overflow vulnerability (37a8603d-4494-11de-bea7-000c29a67389)

Medium Nessus Plugin ID 38838


The remote FreeBSD host is missing one or more security-related updates.


NLnet Labs :

A one-byte buffer overflow has been reported in NSD. The problem affects all versions 2.0.0 to 3.2.1. The bug allows a carefully crafted exploit to bring down your DNS server. It is highly unlikely that this one byte overflow can lead to other (system) exploits.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 38838

File Name: freebsd_pkg_37a8603d449411debea7000c29a67389.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2009/05/20

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:nsd, p-cpe:/a:freebsd:freebsd:nsd2, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2009/05/19

Vulnerability Publication Date: 2009/05/19

Reference Information

CVE: CVE-2009-1755

CWE: 189