Slackware 10.2 / 11.0 / 12.0 / 12.1 / 12.2 / current : cyrus-sasl (SSA:2009-134-01)

High Nessus Plugin ID 38778

Synopsis

The remote Slackware host is missing a security update.

Description

New cyrus-sasl packages are available for Slackware 10.2, 11.0, 12.0, 12.1, 12.2, and -current to fix a security issue. A buffer overflow in the sasl_encode64() function could lead to a denial of service or possible execution of arbitrary code.

Solution

Update the affected cyrus-sasl package.

See Also

http://www.nessus.org/u?a538aa80

Plugin Details

Severity: High

ID: 38778

File Name: Slackware_SSA_2009-134-01.nasl

Version: 1.13

Type: local

Published: 2009/05/15

Updated: 2018/08/09

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:cyrus-sasl, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:10.2, cpe:/o:slackware:slackware_linux:11.0, cpe:/o:slackware:slackware_linux:12.0, cpe:/o:slackware:slackware_linux:12.1, cpe:/o:slackware:slackware_linux:12.2

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Patch Publication Date: 2009/05/14

Reference Information

CVE: CVE-2009-0688

SSA: 2009-134-01

CWE: 119