openSUSE 10 Security Update : xpdf (xpdf-6182)

critical Nessus Plugin ID 38182

Synopsis

The remote openSUSE host is missing a security update.

Description

Specially crafted PDF files could lead to crashes, make the viewer run into an infinite loop or potentially even allow execution of arbitrary code.

(CVE-2009-0165, CVE-2009-0146, CVE-2009-0147, CVE-2009-0166, CVE-2009-0799, CVE-2009-0800, CVE-2009-1179, CVE-2009-1180, CVE-2009-1181, CVE-2009-1182, CVE-2009-1183)

Solution

Update the affected xpdf packages.

Plugin Details

Severity: Critical

ID: 38182

File Name: suse_xpdf-6182.nasl

Version: 1.10

Type: local

Agent: unix

Published: 4/27/2009

Updated: 1/14/2021

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Critical

Base Score: 10

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:xpdf, p-cpe:/a:novell:opensuse:xpdf-tools, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 4/17/2009

Reference Information

CVE: CVE-2009-0146, CVE-2009-0147, CVE-2009-0165, CVE-2009-0166, CVE-2009-0799, CVE-2009-0800, CVE-2009-1179, CVE-2009-1180, CVE-2009-1181, CVE-2009-1182, CVE-2009-1183

CWE: 20, 119, 189, 399