openSUSE 10 Security Update : glib2 (glib2-6209)

Medium Nessus Plugin ID 38181


The remote openSUSE host is missing a security update.


Large strings could lead to a heap overflow in the base64 encoding and decoding functions. Attackers could potentially exploit that to execute arbitrary code (CVE-2008-4316).


Update the affected glib2 packages.

Plugin Details

Severity: Medium

ID: 38181

File Name: suse_glib2-6209.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2009/04/27

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:glib2, p-cpe:/a:novell:opensuse:glib2-32bit, p-cpe:/a:novell:opensuse:glib2-devel, p-cpe:/a:novell:opensuse:glib2-lang, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/04/22

Reference Information

CVE: CVE-2008-4316

CWE: 189