Mandriva Linux Security Advisory : ipsec-tools (MDVSA-2008:181)

High Nessus Plugin ID 37703


The remote Mandriva Linux host is missing one or more security updates.


Two denial of service vulnerabilities were discovered in the ipsec-tools racoon daemon, which could allow a remote attacker to cause it to consume all available memory (CVE-2008-3651, CVE-2008-3652).

The updated packages have been patched to prevent these issues.


Update the affected packages.

Plugin Details

Severity: High

ID: 37703

File Name: mandriva_MDVSA-2008-181.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2009/04/23

Modified: 2016/11/28

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:ipsec-tools, p-cpe:/a:mandriva:linux:lib64ipsec-devel, p-cpe:/a:mandriva:linux:lib64ipsec0, p-cpe:/a:mandriva:linux:lib64ipsec0-devel, p-cpe:/a:mandriva:linux:libipsec-devel, p-cpe:/a:mandriva:linux:libipsec0, p-cpe:/a:mandriva:linux:libipsec0-devel, cpe:/o:mandriva:linux:2007.1, cpe:/o:mandriva:linux:2008.0, cpe:/o:mandriva:linux:2008.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2008/08/28

Reference Information

CVE: CVE-2008-3651, CVE-2008-3652

MDVSA: 2008:181

CWE: 200, 399