CVE-2008-3652

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

src/racoon/handler.c in racoon in ipsec-tools does not remove an "orphaned ph1" (phase 1) handle when it has been initiated remotely, which allows remote attackers to cause a denial of service (resource consumption).

References

http://lists.apple.com/archives/security-announce/2009/Jun/msg00005.html

http://lists.apple.com/archives/security-announce/2009/May/msg00002.html

http://lists.opensuse.org/opensuse-security-announce/2008-11/msg00001.html

http://lists.opensuse.org/opensuse-security-announce/2009-02/msg00002.html

http://secunia.com/advisories/31478

http://secunia.com/advisories/31624

http://secunia.com/advisories/32759

http://secunia.com/advisories/32971

http://secunia.com/advisories/35074

http://security.gentoo.org/glsa/glsa-200812-03.xml

http://sourceforge.net/mailarchive/forum.php?thread_name=48a0c7a0.qPeWZAE0PY8bDDq%2B%25olel%40ans.pl&forum_name=ipsec-tools-devel

http://support.apple.com/kb/HT3549

http://support.apple.com/kb/HT3639

http://www.mandriva.com/security/advisories?name=MDVSA-2008:181

http://www.redhat.com/support/errata/RHSA-2008-0849.html

http://www.securityfocus.com/bid/30657

http://www.securitytracker.com/id?1020692

http://www.ubuntu.com/usn/usn-641-1

http://www.us-cert.gov/cas/techalerts/TA09-133A.html

http://www.vupen.com/english/advisories/2008/2378

http://www.vupen.com/english/advisories/2008/2844

http://www.vupen.com/english/advisories/2009/1297

http://www.vupen.com/english/advisories/2009/1621

https://exchange.xforce.ibmcloud.com/vulnerabilities/44424

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10448

Details

Source: MITRE

Published: 2008-08-13

Updated: 2017-09-29

Type: CWE-399

Risk Information

CVSS v2

Base Score: 7.8

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:C

Impact Score: 6.9

Exploitability Score: 10

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:ipsec-tools:ipsec-tools:*:*:*:*:*:*:*:*

Tenable Plugins

View all (22 total)

IDNameProductFamilySeverity
79457OracleVM 2.1 : ipsec-tools (OVMSA-2009-0010)NessusOracleVM Local Security Checks
high
67741Oracle Linux 3 / 4 / 5 : ipsec-tools (ELSA-2008-0849)NessusOracle Linux Local Security Checks
high
60468Scientific Linux Security Update : ipsec-tools on SL3.x, SL4.x, SL5.x i386/x86_64NessusScientific Linux Local Security Checks
high
51758SuSE 10 Security Update : novell-ipsec (ZYPP Patch Number 5888)NessusSuSE Local Security Checks
high
41246SuSE9 Security Update : ipsec-tools (YOU Patch Number 12259)NessusSuSE Local Security Checks
high
40080openSUSE Security Update : novell-ipsec-tools (novell-ipsec-tools-389)NessusSuSE Local Security Checks
high
39992openSUSE Security Update : ipsec-tools (ipsec-tools-223)NessusSuSE Local Security Checks
high
38744Mac OS X 10.5.x < 10.5.7 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
critical
38743Mac OS X Multiple Vulnerabilities (Security Update 2009-002)NessusMacOS X Local Security Checks
critical
37703Mandriva Linux Security Advisory : ipsec-tools (MDVSA-2008:181)NessusMandriva Local Security Checks
high
35680openSUSE 10 Security Update : novell-ipsec-tools (novell-ipsec-tools-5887)NessusSuSE Local Security Checks
high
35442FreeBSD : ipset-tools -- Denial of Service Vulnerabilities (abcacb5a-e7f1-11dd-afcd-00e0815b8da8)NessusFreeBSD Local Security Checks
high
35020GLSA-200812-03 : IPsec-Tools: racoon Denial of ServiceNessusGentoo Local Security Checks
high
34740SuSE 10 Security Update : ipsec-tools (ZYPP Patch Number 5638)NessusSuSE Local Security Checks
high
34739openSUSE 10 Security Update : ipsec-tools (ipsec-tools-5630)NessusSuSE Local Security Checks
high
34711Fedora 8 : ipsec-tools-0.7.1-5.fc8 (2008-9016)NessusFedora Local Security Checks
high
34710Fedora 9 : ipsec-tools-0.7.1-5.fc9 (2008-9007)NessusFedora Local Security Checks
high
34116Ubuntu 6.06 LTS / 7.04 / 7.10 / 8.04 LTS : ipsec-tools vulnerabilities (USN-641-1)NessusUbuntu Local Security Checks
high
34054RHEL 3 / 4 / 5 : ipsec-tools (RHSA-2008:0849)NessusRed Hat Local Security Checks
high
34052CentOS 3 / 4 / 5 : ipsec-tools (CESA-2008:0849)NessusCentOS Local Security Checks
high
5023Mac OS X 10.5 < 10.5.7 Multiple VulnerabilitiesNessus Network MonitorGeneric
critical
800792Mac OS X 10.5 < 10.5.7 Multiple VulnerabilitiesLog Correlation EngineOperating System Detection
high