FreeBSD : xchat remotely exploitable buffer overflow (Socks5) (8338a20f-9573-11d8-9366-0020ed76ef5a)

High Nessus Plugin ID 37503


The remote FreeBSD host is missing a security-related update.


A straightforward stack-based buffer overflow exists in XChat's Socks5 proxy support.

The XChat developers report that `tsifra' discovered this issue.

NOTE: XChat Socks5 support is disabled by support in the FreeBSD Ports Collection.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 37503

File Name: freebsd_pkg_8338a20f957311d893660020ed76ef5a.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2009/04/23

Modified: 2014/06/05

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:xchat2, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2004/04/23

Vulnerability Publication Date: 2004/04/05

Reference Information

CVE: CVE-2004-0409