FreeBSD : qpopper format string vulnerability (ebdf65c7-2ca6-11d8-9355-0020ed76ef5a)

High Nessus Plugin ID 37275


The remote FreeBSD host is missing a security-related update.


An authenticated user may trigger a format string vulnerability present in qpopper's UIDL code, resulting in arbitrary code execution with group ID `mail' privileges.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 37275

File Name: freebsd_pkg_ebdf65c72ca611d893550020ed76ef5a.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2009/04/23

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:qpopper, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2003/12/12

Vulnerability Publication Date: 2000/05/23

Reference Information

CVE: CVE-2000-0442

BID: 1242