Mandrake Linux Security Advisory : pcre (MDKSA-2007:211)

High Nessus Plugin ID 37237


The remote Mandrake Linux host is missing one or more security updates.


Multiple vulnerabilities were discovered by Tavis Ormandy and Will Drewry in the way that pcre handled certain malformed regular expressions. If an application linked against pcre, such as Konqueror, parses a malicious regular expression, it could lead to the execution of arbitrary code as the user running the application.

Updated packages have been patched to prevent this issue.


Update the affected packages.

Plugin Details

Severity: High

ID: 37237

File Name: mandrake_MDKSA-2007-211.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2009/04/23

Modified: 2016/11/28

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64pcre-devel, p-cpe:/a:mandriva:linux:lib64pcre0, p-cpe:/a:mandriva:linux:libpcre-devel, p-cpe:/a:mandriva:linux:libpcre0, p-cpe:/a:mandriva:linux:pcre, cpe:/o:mandriva:linux:2007.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2007/11/08

Reference Information

CVE: CVE-2006-7230, CVE-2007-1659, CVE-2007-1660, CVE-2007-1661, CVE-2007-1662, CVE-2007-4766, CVE-2007-4767, CVE-2007-4768

MDKSA: 2007:211

CWE: 119, 189